installation

A collection of 1 post
Configuring and Installing PETSc for Underworld
petsc

Configuring and Installing PETSc for Underworld

The following is compatible with Ubuntu 20.04 under Windows 10/11 WSL 2 (Windows Subsystem for Linux). PETSc, the Portable, Extensible Toolkit for Scientific Computation is the main dependency required for building Underworld. In the following, I will describe my current workflow for configuring and installing PETSc on Linux.
4 min read